代潇瑞博客

mysql版本和操作系统不同也能配主从复制

| 点击次数:4720

网上有些文章说mysql复制(复制就是常说的主从)必须要相同的系统、相同配置和相同的mysql版本,其实并不一定需要相同。


如果用于生产环境,那么毫不犹豫选择相同mysql版本和相同的操作系统;但是如果是用于学习测试,并不一定有如此条件,即便不同,也是没问题的。


本人windows下的mysql版本是5.5.39(主),centos下的mysql版本是5.6.38(备),已经测试通过,MyISAM、InnoDB均可以同步。


注意:

如果mysql版本不一致,请选择低版本的作为主库,因为mysql复制大部分是向后兼容的,新版本的服务器可以作为旧版本的备库,反过来可能会有问题。但对于小版本,如5.5.31、5.5.32则通常是兼容的。


温馨提示:

1、复制功能通常不会增加主库的开销,主要是启用二进制文件带来的开销和一些网络开销。

2、复制功能通常会有一些延时,所以为了保持更低的复制延时,请保证有一个稳定的、低延迟连接的环境。

【相关推荐】

触屏版 | 电脑版

Copyright © 2013 代潇瑞博客手机版

QQ: 446673330

粤ICP备13071969号-1